How to remove a connector entry in the Connector Configuration list
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Article ID: 99931
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Updated On:
Products
CA Service Operations Insight (SOI)
Issue/Introduction
An SOI connector was uninstalled and removed from the environment. The connector still appears in the SOI dashboards Administration tab under the Connector Configuration list after restarting SOI services on the connector server. How can you remove this connector entry so that it is no longer listed.
Environment
SOI 3.3, 4.0, or 4.2.
Cause
This is normally due to a left over connector entry in the SAMStores ConnectorConfiguration table.
Resolution
Their are two procedures documented below for this depending on whether you have an Integration Services or Catalyst Container based connector.
For an Integration Services based connector follow these steps: 1. On the connector server stop the "CA SOI Integration Services" service.
2. Once connector is offline in the SOI Dashboard click on the Remove Connector button.
3. Check the following table in the SAMStore database by running this query: select * from ConnectorConfiguration You will see a ConnectorName column, make sure the old one is not listed.
4. If it is listed, delete the entry from the table by running the following SQL query: delete from ConnectorConfiguration where ConnectorID = <ConnectorID Value> <ConnectorID Value> is listed in the ConnectorID column from the output of step 3.
5. Start the "CA SOI Integration Services" service on the connector server.
6. You will also need to recycle the SOI manager for the change to take effect.
For an Catalyst Container based connector follow these steps: 1. On the connector server stop the "CA Catalyst Container CatalystConnector" service.
2, Once connector is offline in the SOI Dashboard click on the Remove Connector button.
3. Once the connector is removed go to the connector server and delete the following cache files: - All files/folders from CA\Catalyst\CatalystConnector\container\data folder (except the Core folder) - All files/folders from CA\Catalyst\CatalystConnector\container\data\Core folder (except the Catalogpolicy folder if it exists) - All files/folders from \CA\Catalyst\CatalystConnector\container\nls-store - All files/folders from \CA\Catalyst\CatalystConnector\container\registry-cache
4. Check the following table in the SAMStore database by running this query: select * from ConnectorConfiguration You will see a ConnectorName column, make sure the old one is not listed.
5. If it is listed, delete the entry from the table by running the following SQL query: delete from ConnectorConfiguration where ConnectorID = <ConnectorID Value> <ConnectorID Value> is listed in the ConnectorID column from the output of step 4.
6. Start the "CA Catalyst Container CatalystConnector" service on the connector server.
7. You will also need to recycle the SOI manager for the change to take effect.