office365 probe is unable to connect to the Microsoft servers
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office365 probe is unable to connect to the Microsoft servers

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Article ID: 99864

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I have configured the office365 probe via MCS according to the probe documentation however the profile is in error and I can see the following error message in the probe log:

Office365Monitoringapp is not responding (reason: Connection and/or inventory update failure) {Could not retrieve OAuth access token for client with details com.ca.ce.auth.oauth2.OAuth2Details@....

Environment

office365 1.0

Cause

The robot where the office365 probe is running needs access to the Office 365 servers on the internet and the office365 v1.0 probe does not have a proxy feature.

Resolution

Deploy the office365 probe to a robot with access to the internet.