Having Disk Full with idm wildfly.log of messages telling that The server supports a maximum of 2100 parameters
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Having Disk Full with idm wildfly.log of messages telling that The server supports a maximum of 2100 parameters

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Article ID: 99831

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

It's getting DISK FULL  in Identity Manager wildfly server.log repeating message from ims.tmt.persistence as shows:

ERROR [ims.tmt.persistence] (Thread-2 (HornetQ-client-global-threads-950818477)) PersistenceProvider: JMS:ID:23c4b4ec-6399-11e8-8948-73aeb0fbe1df: getTaskSessionEventList() 23904e91-b16b6927-cfb3bdb1-a8a0b0: com.microsoft.sqlserver.jdbc.SQLServerException: The incoming request has too many parameters. The server supports a maximum of 2100 parameters. Reduce the number of parameters and resend the request. 

 

Environment

1. CA Identity Suite Virtual Appliance version 14.2.0 - NON_PRODUCTION mode 
2. External Database is SQL 2014 StandarD Edition SP2 
3. Deployment map:

machine1:improvisioning,wildfly-ig,wildfly-idm,wildfly-portal,im_jcs,userstore 
machine2: userstore,improvisioning,wildfly-ig,wildfly-idm,wildfly-portal,im_jcs 
machine3  external database 

 

Cause

This may indicate a loop generated in a Policy Xpress that by mistake being executed an infinite cycle modifying the user and synchronize it.

Resolution

1. Enable the DEBUG of logging.jsp following the steps from docops available in this link from docops

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-suite/14-2/virtual-appliance/configuring-virtual-appliance.html

Open the link and search in the page the title: 

"Modify CA Identity Manager Application Log Level" 

2. With the debug enabled for im and ims it's possible identify the task  causing the issue having abnormally a bunch number of events. 
This following sql statment shows this in the log in DEBUG: 

select * from event12_5 WITH (NOLOCK) where tasksessionid=? and type in (?, ?, ?, ?) (5658c0e3-c81e3e2d-a1d8fa98-7b48f6,2,34,4,36) 

The 5658c0e3-c81e3e2d-a1d8fa98-7b48f6 correspnods to the taskid

3.  If want can cancel this task 

a. Go to System, Open View Submitted Tasks 
b. Select this options: 
c. "Task ID equais" and paste the "5658c0e3-c81e3e2d-a1d8fa98-7b48f6" for this field (value got from DEBUG mode done previuosly)
d.  Click in Search 
e. If list the task. Please, get the status of this task, if this is in progress we need to CANCEL this. 
f. If not show, try also enable the button "Show unsubmitted tasks" togheter. 

4. If you can cancel this task or not you may need purge this task from task persistence using these steps: 

a. Go to System / Cleanup Submitted Tasks / Execute Now / Next 
b. Do the criteria that will cancel the task and mark the option "Cancel In Progress Tasks Only" if the task is in Progress....
(** Warning: You may cancel the problematic task and also other tasks that are in Progress so take care doing the search criteria in this page **) 
c. After you select click in "Finish" and check if task is now canceled. 

5. At this point with task canceled, check if message continues repeating in the wildfly.log. It's possible now to a  cleanup this task returning to task "Cleanup Submitted Task" and doing the Criteria to purge this task from DB repeating the step 4, but now not selecting the option "Cancel In Progress Tasks Only"