Install Domain Cluster Node Fails
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Install Domain Cluster Node Fails

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Article ID: 98941

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Updated On:

Products

CA Process Automation Base Process Automation Manager

Issue/Introduction

When installing a secondary node for a domain cluster the PAM Domain Node installer (not Third Party Installer) fails.

The primary server is configured with secure comms, with an Nginx load balancer pointing to the primary node.
The secondary node installation is run by logging into the primary server and running the install from the installation page in the UI.

The installation.jnlp file appears to be configured incorrectly, notably the following section:

<application-desc main-class="class.optunity.c2o.util.LaunchInstaller">
<argument>https://<Load Balancer FQDN>:null or wrong port number/</argument>  (<=== should have port 443 here)
<argument>Add New Node</argument>
<argument><Load Balancer FQDN></argument>
<argument>80</argument>
<argument>http://<Load Balancer FQDN>:80/</argument>
<argument>true</argument>
<argument>443</argument>
<argument>false</argument>
<argument>null</argument>
<argument>null</argument>
<argument>null</argument>
<argument>null</argument>
<argument>false</argument>
</application-desc>


This causes the installation to not even launch. Changing the https://<Load Balancer FQDN>:null/ value to https://<Load Balancer FQDN>:443/ enables the install to run, but it will encounter an error such as "connection refused" in the <PAM installation folder>\wildfly\standalone\installation.log file later, due to the null or incorrect port value.

Environment

IT Process Automation v4.x

Cause

Some port numbers in the ITPAM installation are corrupted or were not entered correctly.  These can be manually changed in the configuration files, but these configuration settings are also in the database.  During installation, the corrupted settings in the database overwrite the changes made to the configuration files, causing those changes to be ineffectual.  

Resolution

The solution is to reinstall ITPAM on the primary domain orchestrator.  Please follows the below steps so that PAM will create the correct default configuration.

  1. Stop PAM Servers

  2. Run the installation on the primary Domain Orchestrator again, choosing the "Reinstall" option instead of the "Configure" option.  *** Do NOT uninstall ***.  When stepping through the screens in the installation wizard, ensure all settings, especially those for the ports are correct.

  3. Use the following queries to take backup of existing records and delete the records. 

    Taking a backup (SQL Server)
    select * into BackupAgent from Agent
    select * into BackupConfigObject from ConfigObject
    select * into BackupConfigObjectMetaData from ConfigObjectMetaData
    select * into BackupConfigObjectProps from ConfigObjectProps
    select * into BackupDomain from Domain
    select * into BackupEnvironment from Environment
    select * into BackupGroupProperties from GroupProperties
    select * into BackupOrchestrator from Orchestrator
    select * into BackupOrchestratorTP from OrchestratorTP
    select * into BackupPropertiesXML from PropertiesXML
    select * into BackupTPGroup from TPGroup

    Taking a backup (Oracle)
    create table BackupAgent as select * from Agent;
    create table BackupConfigObject as select * from ConfigObject;
    create table BackupConfigObjectMetaData as select * from ConfigObjectMetaData;
    create table BackupConfigObjectProps as select * from ConfigObjectProps;
    create table BackupDomain as select * from Domain;
    create table BackupEnvironment as select * from Environment;
    create table BackupGroupProperties as select * from GroupProperties;
    create table BackupOrchestrator as select * from Orchestrator;
    create table BackupOrchestratorTP as select * from OrchestratorTP;
    create table BackupPropertiesXML as select * from PropertiesXML;
    create table BackupTPGroup as select * from TPGroup;;-
    commit;

    Delete queries
    delete from Agent
    delete from ConfigObject
    delete from ConfigObjectMetaData
    delete from ConfigObjectProps
    delete from Domain
    delete from Environment
    delete from GroupProperties
    delete from Orchestrator
    delete from OrchestratorTP
    delete from PropertiesXML
    delete from TPGroup


  4. Start PAM Server on the Domain Orchestrator and restart installation of second node.  All the port numbers and other settings in the JNLP file should now be correct.

Additional Information

Information on the correct port numbers to enter for ITPAM can be found here: Ports Used by CA Process Automation

In particular, ensure the correct settings for these screens in the installation wizard: