CA UIM - Vmware Hypervisor State Error / Red Cross X
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CA UIM - Vmware Hypervisor State Error / Red Cross X

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Article ID: 98659

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We use a VMware probe to monitor our VMware environment. We have multiple ESXi hosts.

On one of our hosts the Hypervisor State has a red cross. I don't see any alarms for this host. Also, when I check the server in Vcenter I do not see an alarm.

Why is the Hypervisor state in error? 

Environment

vmware probe

Cause

USM uses QOS value of [Status] monitor for ESXi host in vmware probe.
You may want to check value in S_QOS_SNAPSHOT table.

--------------------------------------------------------------- 
select table_id from S_QOS_DATA where 
qos = 'QOS_STATUS' and 
probe = 'vmware' and 
source = '<ESXi Host device Name>' 
--------------------------------------------------------------- 

--------------------------------------------------------------- 
select * from S_QOS_SNAPSHOT where 
table_id = <table_id of 1st sql> 
--------------------------------------------------------------- 

QOS value would be [0 (gray), 1 (green), 2 (yellow), 3 (red)] 

USM fetch S_QOS_SNAPSHOT table, to find out what is the latest QOS value for ESXi host status.

Resolution

We've seen this previously with older versions of the vmware probe. By default, QOS of [Status] monitor for hypervisor (ESXi host) should be enabled. However, in some cases monitoring against the host status might be disabled (most likely caused by data corruption within the configuration file). Enabling the qos for this host should resolve the issue and the hypervisor state will turn into a green checkmark, as expected.