SpectrumProxy.war reports not deployed
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SpectrumProxy.war reports not deployed

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Article ID: 97962

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Updated On:

Products

CA Spectrum

Issue/Introduction

We are integrating Spectrum with CABI Jaspersoft. As per the instructions we have downloaded SpectrumConfigInstaller.jar from OneClick and ran this on Jaspersoft server
  1. <CABI Install folder path>\java\bin\java -jar <spectrumConfigInstaller.jar file path>\spectrumConfigInstaller.jar -install

We have also restarted Jaspersoft tomcat and ran ReDeploy from the OneClick > Report Manager > Jaspsrsoft integration page. 

However we are seeing an error in the Jaspersoft Tomcat log regarding SpectrumProxy.war:

23-May-2018 21:48:58.457 INFO [localhost-startStop-3] org.apache.catalina.startup.HostConfig.deployWAR Deploying web application archive /opt/CA/SharedComponents/CA Business Intelligence/apache-tomcat/webapps/SpectrumProxy.war 
23-May-2018 21:48:58.465 SEVERE [localhost-startStop-3] org.apache.catalina.startup.ContextConfig.beforeStart Exception fixing docBase for context [/SpectrumProxy] 
java.util.zip.ZipException: error in opening zip file 

23-May-2018 21:48:58.468 SEVERE [localhost-startStop-3] org.apache.catalina.startup.HostConfig.deployWAR Error deploying web application archive /opt/CA/SharedComponents/CA Business Intelligence/apache-tomcat/webapps/SpectrumProxy.war 
java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/SpectrumProxy]] 
 

Environment

Spectrum integrated with Jaspersoft
 

Cause

The SpectrumProxy.war may not have copied over properly and may be a corrupted file. 

Resolution

Try running SpectrumConfigInstaller again, or try manually copying SpectrumProxy.war over to Jaspersoft server. Restart Tomcats, run Re-Deploy. Verify the files on Jaspersoft have been updated. 

1. From OneClick Admin page > Report Manager > Jaspersoft integration page, download SpectrumConfigInstaller.jar

2. Copy the file to the Jaspersoft server and run the command:

<CABI Install folder path>\java\bin\java -jar <spectrumConfigInstaller.jar file path>\spectrumConfigInstaller.jar -install

3. The SpectrumConfigInstaller.jar copies over several more files to Jaspersoft server. Verify the time/date on the files to ensure they have been copied over: 

/webapps/jasperserver-pro/optimized-scripts/bower_components/jrs-ui/src/reportViewer/reportViewerMain.js 
/webapps/SpectrumProxy.war 
/webapps/jasperserver-pro/WEB-INF/applicationContext-WebServiceDataSource.xml 
/webapps/jasperserver-pro/WEB-INF/bundles/webserviceds.properties 
/webapps/jasperserver-pro/WEB-INF/lib/customDatasource_WebService_JRS_wrapper.jar 
/webapps/jasperserver-pro/WEB-INF/lib/fluent-hc-4.2.1.jar 
/webapps/jasperserver-pro/WEB-INF/lib/WebServiceDataAdapter.jar 
/webapps/jasperserver-pro/WEB-INF/bundles/DashboardBundle.properties 
/webapps/jasperserver-pro/WEB-INF/lib/spectrum_utils.jar 

4. Restart Jaspersoft Tomcat server

5. Run ReDeploy from OneClick Admin > Report Manager > Jaspersoft Integration

6. Log into Jaspersoft and run some test reports

If you still have issue, double check Jaspersoft Tomcat log for SpectrumProxy.war errors

You can also try manually copying SpectrumProxy.war to Jaspersoft server 

1. Copy the SpectrumProxy.war file from the location $SPECROOT\Spectrum\Install-Tools\SRM-Tools\jasper\ of the OneClick+SRM host to Japserserver\tomcat\webapps folder (C:\Program Files\CA\SC\CA Business Intelligence\apache-tomcat\webapps\) of the JasperReports server

2. Restart Jaspersoft Tomcat

3. Run ReDeploy

4. Test logging in to Jaspersoft and run reports

Additional Information

Please reference the "Spectrum with Unified Dashboards and Reporting for Infrastructure Management" section of the documentation for more information.