View filtering in Dashboard Edit page doesn't work
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View filtering in Dashboard Edit page doesn't work

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Article ID: 97940

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

The Views filter in the Dashboard Editor isn't filtering properly when setting a specific Context to narrow the View choices presented.

When creating a new Dashboard, setting Context to a “Response Path ICMP Jitter” component element, no Response Test OOTB Views are suggested. 

Doing the same for a "Response Path ICMP" element the Response Test folder and it's choices specific to "Response Path ICMP" elements are presented as OOTB options.

Environment

All supported CA Performance Manager releases

Cause

Per follow up from Product Management.
 
"This wouldn’t be a defect but an enhancement. We are targeting some significant improvements to dashboard and view creation (hopefully later this year) and I will certainly note this use case as we consider the requirements for that work."

Resolution

1: Pick an existing default Response Path View and edit it to suit the needs of a different test type. Or change one of the Custom options to meet your needs. 

2: Submit an Enhancement Request via the CA Performance Management Communities site Idea posts. The more up votes it gets, the more likely it will get done.

3: Reach out to your Account Management team to engage the CA Performance Management Product Management team for further discussions.

Additional Information

CA Performance Management Communities site.

https://communities.ca.com/community/performance-management/