Tasks scheduled to finish in future are marked as late
search cancel

Tasks scheduled to finish in future are marked as late

book

Article ID: 97136

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

For one of our projects, when we open the project schedule into the Gantt Chart, we see that some of the tasks show up as late. However, the task finish date hasn't passed yet and is actually some time later in the future.

Why are the tasks showing up as late and how can we resolve it so that they're back on schedule?

Environment

All supported PAS releases.

Cause

This is caused by how the status of a task is calculated, and in particular the days late. Below is a snippet from the documentation of how a late status for a task is determined, and if so, how many days the task is late by.
 
Days Late
Displays the number of days late considering the following:
  • Whether or not a baseline exists
  • Project/task progress
 
If a baseline exists, then days late is calculated as project/task finish date minus baseline finish date. A positive number indicates that the project/task is late according to the baseline. A negative number indicates that it is early according to the baseline.

If a baseline exists and the project/task finish date is the same as the baseline finish date, then the project/task is considered late if it is not completed and it was due before today’s date. In this case, days late is calculated as today’s date minus project/task finish date.

If there is no baseline, then days late is calculated if the project/task is not completed and it was due before today’s date. In this case, days late is calculated as today’s date minus project/task finish date.


In this scenario, the tasks are being determined as late because they have a Finish Date which is after the Baseline Finish Date. This is by design according to the first clause, which applies because there is a baseline for the project. Thus, the days late value is being calculated by the formula
 
Days Late = (Task Finish Date - Task Baseline Finish Date)
 
With the above, the Days Late value will be positive, meaning the task is late according to the baseline finish date, causing it to display as late in the Gantt Chart and the Task List page.

Resolution

To have the tasks show up in good standing such that they are no longer marked as late, create a new baseline for the project either manually or after auto-scheduling. At that point, the Baseline Finish Dates for the tasks should either be on the same date as, or after, the scheduled Finish Date for the tasks.

They will no longer be displayed as late following the above.

Additional Information

  • See the Days Late section of the documentation for the Project Schedule Report to understand how that value, and status of a task, is calculated. This holds true, and is applicable, for the Gantt Chart as well.
  • Please note that the explanation provided here is specific to PMO Accelerator contents. It is not applicable to the "Is Late" field in the Tasks module. For an explanation on how that particular filed works, refer to the KB here.