When setting up recording, the VSE is not visible in the Portal
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When setting up recording, the VSE is not visible in the Portal

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Article ID: 95951

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Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder) Service Virtualization

Issue/Introduction

When setting up a virtual service recording session it is not possible to select the VSE as it does not appear in the dropdown list.

Recordings have previously worked. 

In the vse.log, notices are seen that the service cannot be created in the directory vsBuilderSessions/<VSE_NAME>_<VSE_PORT> where VSE_NAME and VSE_PORT reference the VSE that cannot be selected. An example of the directory name is vsBuilderSessions/VSE_2013

Environment

All supported DevTest releases.

Cause

Previous recording session files in the appropriate directory under vsBuilderSession are corrupt or incomplete. When scanning these files the error parsing them prevents the VSE from being reported as available to process further recordings. This folder is used by the virtualisation API, and thus the Portal.

Resolution

Since these files are transitory, being valid only for the specified recording session, they may safely be deleted. Take the following actions
  1. Shut down the VSE 
  2. Rename the folder vsBuilderSessions/<VSE_NAME>_<VSE_PORT> (for instance vsBuilderSessions/VSE_2013)
  3. Restart the VSE