CA Identity Manager: Environment IdentityEnv is stopping by itself
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CA Identity Manager: Environment IdentityEnv is stopping by itself

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Article ID: 95742

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

CA Identity Manager environment IdentityEnv stops by itself and after recycle the appliance starts again.
However after a short while the "IdentityEnv" envionment stops by itself again.

Environment

CA Identity Suite Virtual Appliance 14.0 or 14.1
The internal OS is CentOS

Cause

1. Start checking the disk space of CentOS using the command df -k

In this following example shows Use% of / filesystem with 50% usage that is good.


Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/vg_ca--vapp-lv_root
                      49099068  23302364  23305904  50% /
tmpfs                  5063084    681452   4381632  14% /dev/shm
/dev/sda1               495844     52884    417360  12% /boot


2. You should worry when the Use% is above 70%. It's recommended leave space in filesystem

The restart may happen when the %Use is 100% of / filesystem space.

3. Also review inside logs as IDM wildfly log server.log that is present in the folder /opt/CA/VirtualAppliance/logs/IDM_logs/server.log can have this error:

YYYY-MM-DD HH:MM:SS,643 WARN [org.hornetq.core.server] (JournalImpl::FilesExecutor) HQ222010: Critical IO Error, shutting down the server. file=NIOSequentialFile /opt/CA/wildfly-idm/standalone/data/live-hornetq/journal/hornetq-data-144199.hq.tmp, message=No space left on device: HornetQIOErrorException[errorType=IO_ERROR message=No space left on device] 

Resolution

1. Login with config user in CentOs Virtual Machines and check inside of folder /opt/CA/VirtualAppliance/logs that have links for each separated component as shows in following example.

Each one in yellow is a symbolic link to each folder of components

total 692
-rwxr-xr-x 1 root root      1 May 14 17:05 alarm.log
-rwxrwxr-t 1 root root  14756 May 11 17:43 ca_vapp_deployment.log
-rwxr-x--- 1 root root      0 Oct 26  2017 ca_vapp_deployment.log.BAK
-rwxrwxr-t 1 root root 382190 May 11 17:43 ca_vapp_main.log
-rwxrwxr-t 1 root root 285178 May 11 17:43 ca_vapp_webui.log
-rwxr-xr-x 1 root root   4776 Jul  3  2017 compressLogs
lrwxrwxrwx 1 root root     49 Jul 31  2017 ConnectorServer_logs -> /opt/CA/IdentityManager/ConnectorServer/jcs/logs/
lrwxrwxrwx 1 root root     32 Jul 31  2017 Directory_logs -> /opt/CA/Directory/dxserver/logs/
lrwxrwxrwx 1 root root     35 Jul 31  2017 IDM_logs -> /opt/CA/wildfly-idm/standalone/log/
lrwxrwxrwx 1 root root     34 Jul 31  2017 IG_logs -> /opt/CA/wildfly-ig/standalone/log/
lrwxrwxrwx 1 root root     38 Jul 31  2017 IP_logs -> /opt/CA/wildfly-portal/standalone/log/
lrwxrwxrwx 1 root root     38 Jul 31  2017 Oracle_logs -> /u01/app/oracle/diag/rdbms/xe/XE/trace
lrwxrwxrwx 1 root root     48 Jul 31  2017 ProvisioningServer_logs -> /opt/CA/IdentityManager/ProvisioningServer/logs/

2. Enter in individual folders and check if have old files to remove using Unix based commands. 




 

Additional Information

a. for folder /opt/CA/IdentityManager/ProvisioningServer/logs the user is imps so need do the command a su - imps before try remove files.
b. for folder /opt/CA/Directory/dxserver/logs/ the owner of files is dsa, so in same way necessary su - dsa from config user.