A CA DADS Plus for CICS Batch Interface job to deallocate of a class of RLS files hangs for 60 minutes.
search cancel

A CA DADS Plus for CICS Batch Interface job to deallocate of a class of RLS files hangs for 60 minutes.

book

Article ID: 95558

calendar_today

Updated On:

Products

DADS Plus

Issue/Introduction

The client encountered a hang with an existing CA DADS Plus for CICS batch interface job that runs weekly without any problems. On this particular night the batch interface deallocate of the class of 30  RLS files hung for at least 60 minutes before the operator had to cancel the batch interface job.

Environment

Z/OS 
CICS 

Cause

The CA DADS PLUS for CICS batch interface job request is to close and deallocate a CLASS of 30 RLS files defined to CICS. On this particular night an application program in CICS had an ENQ on one of the files in the CLASS and would not release the ENQ. The CA DADS Plus batch job deallocated some of the files in the CLASS until it encountered the problem file. CA DADS Plus then attempted every few seconds to deallocate the problem file but the application program still had an ENQ on the file. Since the CA DADS Plus  MAXWAIT= parameter was set to zero(no timeout value) CA DADS plus would keep trying to deallocate the file until the ENQ was released. After sixty minutes the operator cancelled the batch interface job with an S222. This hang caused a delay in the client nightly batch processing.
 

Resolution

The client needs to find out what user application program had the ENQ on the application file. The client can also set the CA DADS Plus for CICS MAXWAIT=30 (30  minutes) so the batch job does not hang until it is cancelled by the operator. When the MAXWAIT=30 is exceeded the batch job will contain the following message base on the NOT ACTIVE PARM.
 
If the client is running with the NOT ACTIVE PARM        QUEUE
 
Then the batch job will fail with a condition code 02 with message
 
CONDITION CODE=000 DADBI020 REQUEST QUEUED FOR THE APPLID.
CONDITION CODE=002 DADBI129 REQUEST(S) NOT COMPLETED WITHIN MAXWAIT
HIGH CONDITION CODE=002
 
If the not active parameter is CANCEL or OPERATOR the client will have to respond to the message below.
 
JOB49621 @138 DADBI906 APPLID=A11IC4S5 MAXIMUM WAIT TIME EXCEEDED. REPLY 'CANCEL', OR 'CONTINUE'
 
The parameters MAXWAIT= and NOT ACTIVE PARM= work in conjunction with one another. These parameters are discussed in the CA DADS PLUS for CICS r 4.0 User’s Guide Chapter 12 page 20.
 
You can view the current settings for these parameters in CICS. To see these parameter in CICS enter transaction DADB at a clear screen in CICS and press Enter. Then select 
PF12-APPL  to see the parameters on the APPLID.

 

Additional Information

CA DADS Plus for CICS batch interface jobs write status messages to the DADSLOG that is attached to the CICS region. To troubleshoot this problem you can search the DADSLOG for the job number of the problem batch job. You can then view the DADSLOG messages for each file in CLASS. Once you find the last file sucessfully processed in the CLASS It’s the next file in the CLASS that has the ENQ on it.

Once the CA DADS Plus batch job has ended  to issue a  CICS CEMT command to close the file (CEMT SET FILE(FCT NAME) CLO)
 
If CEMT cannot close the file CA DADS Plus will not be able to close the file.