Data collector Status in PC is incorrect after Data Aggregator Migration
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Data collector Status in PC is incorrect after Data Aggregator Migration

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Article ID: 95497

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

Data aggregator was migrated from an old server to the new server as the documentation in the wiki after which the Data aggregator and 
Data collector were showing correct status on CA Performance Center however after a restart of the Data aggregator the Data collector status is System health is failed.

Administration/Manage Data Source: all seems OK 
DataCollector: seems to be OK, STATUS green, Collecting Data. Graphs and dashboard seems to be OK. 
But: System health failed. 
If you click on it: Sync Normal, DA Normal, DC: Failed 

Environment

CA Performance Management 3.5
 

Cause

Performance Center is polling the wrong Data aggregator to get the status of the Data collectors.



 

Resolution

Following are the steps to check if Performance center is trying to poll the old Data Aggregator for Data collector status.

a) Login to following URL to enable debug on PC Side

http://PC:8181/pc/center/admin/config/logs?listing=all

Change the Debug levels to Trace for the following 

com.ca.im.portal.services.status.impl.DcStatusServiceProvider
om.ca.im.portal.services.status.impl.Utils

On the PCService.log you should see 

ERROR | Status Poller-thread-1   | 2018-05-11 12:06:47,032 | com.ca.im.portal.services.status.impl.Utils
      | Failed in sending REST: http://oldDA:8581/rest/dcms
java.net.UnknownHostException: oldDA
        at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:184)
        at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
        at java.net.Socket.connect(Socket.java:589)
        at java.net.Socket.connect(Socket.java:538)
        at java.net.Socket.<init>(Socket.java:434)
        at java.net.Socket.<init>(Socket.java:286)
        at org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:80)

If we are seeing the above. Please restart the CA Performance Center Services 

/opt/CA/PerformanceCenter/sso/bin/caperfcenter_sso stop && 
/opt/CA/PerformanceCenter/DM/bin/caperfcenter_devicemanager stop && 
/opt/CA/PerformanceCenter/EM/bin/caperfcenter_eventmanager stop && 
/opt/CA/PerformanceCenter/PC/bin/caperfcenter_console stop &&
/etc/init.d/mysql stop  &&
/etc/init.d/mysql start &&
/opt/CA/PerformanceCenter/sso/bin/caperfcenter_sso start && 
/opt/CA/PerformanceCenter/DM/bin/caperfcenter_devicemanager start && 
/opt/CA/PerformanceCenter/EM/bin/caperfcenter_eventmanager start && 
/opt/CA/PerformanceCenter/PC/bin/caperfcenter_console start

After the Restart the System health should now show the correct status for Data collector.