CA API Portal 3.5 "Fatal transport error: Unexpected response status: 502"
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CA API Portal 3.5 "Fatal transport error: Unexpected response status: 502"

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Article ID: 95167

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Updated On:

Products

CA API Gateway

Issue/Introduction

The following error may occur while applying a Cumulative Release (CR) onto Portal 3.5

# sh upgrade-v3.5.CR7.sh 

Applying v3.5.CR7 update... done

Starting catalina
Waiting for catalina to start, please be patient...

Using host: https://<portal>.<sample>.local
Enter your admin username: admin
Enter your admin password:
Waiting for XSL
Applying patch v3.5.CR7.cmspatch
Skipping patch v3.5.CR1-phrases.cmspatch already applied
Skipping patch v3.5.CR2-phrases.cmspatch already applied
Skipping patch v3.5.CR3-phrases.cmspatch already applied
Skipping patch v3.5.CR3-content.cmspatch already applied
Skipping patch v3.5.CR4-phrases.cmspatch already applied
Skipping patch v3.5.CR6-phrases.cmspatch already applied
Applying patch v3.5.CR7-content.cmspatch
Skipping patch v3.5.CR7-content.cmspatch already applied
Skipping patch v3.5.CR7-content.cmspatch already applied
Skipping patch v3.5.CR7-content.cmspatch already applied
Applying patch v3.5.CR7-phrases.cmspatch
Waiting for queues....
Regnerating template editors
Regenerating standard files
Fatal transport error: Unexpected response status: 502
org.apache.http.client.ClientProtocolException: Unexpected response status: 502
at com.ca.portal.client.CMSClient$1.handleResponse(CMSClient.java:45)
at com.ca.portal.client.CMSClient$1.handleResponse(CMSClient.java:1)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:218)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:160)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:136)
at com.ca.portal.client.CMSClient.main(CMSClient.java:153

Environment

CA API Portal 3.5

Cause

This usually happens when the patch routine process takes longer than what the HTTP services are willing to wait.
The embedded Apache HTTP service has a "timeout" value in its configuration file that is set (out of the box) to 60 seconds. This value defines the amount of time that the services wait for receipts and transmissions during communications. However, in some circumstances, applying a Cumulative Release patch to Portal may take longer than a minute, causing Apache to rise a transport error, which leads to a patch operation failure. This document helps to adjust the timeout to a value that is appropriate for most situations.

Resolution

The following steps should help to fix the problem:

  • Remove any related v3.5.CR(x).done file under /opt/Deployment/lrs folder. This allows Portal to re-run the patch using the upgrade script.
  • Edit /etc/httpd/conf/httpd.conf and change default Timeout value from 60 to 300 seconds.
  • Enable new settings by executing at command prompt: service httpd reload
  • Reinstall the patch.


Another possible cause is an issue with the protections on the files: Please run the following command on the portal to ensure all files have the right owner and group: chown -R l7portal:portalusers /opt/Deployments/lrs/repository