CA Performance Management Data Collector ActiveMQ Errors
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CA Performance Management Data Collector ActiveMQ Errors

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Article ID: 95039

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

One of the  CA Performance Management 3.2 Data Collectors is showing the following error messages in the activemq.log:

2018-01-10 06:40:14,209 | WARN | Transport Connection to: tcp://127.0.0.1:37476 failed: java.io.EOFException | org.apache.activemq.broker.TransportConnection.Transport
| ActiveMQ Transport: tcp:///127.0.0.1:37476@61616

Also we are seeing the following in the karaf.log:

2018-01-10 06:34:41,834 | WARN | eThread-thread-1 | ReliableProxyProcessor |
stributed.ReliableProxyProcessor 49 |184 - com.ca.im.item-repository.impl - 3.2.0.RELEASE-201 | | Timeout:
Response wait time out after 30000 ms

We would like to know if these messages cause any data loss.

Environment

CA Performance Management 3.2

Cause

When a connection is inactive for 30 secs, ActiveMQ closes it. A new one will be created when needed. 
It really is an issue only If we're not getting polled data, or Data Collector is not getting polling/irep updates,
meaning it’s failing to open the connections. 

Resolution

The messages are warnings and will not cause data loss and may be in conjunction with other messages it can.
Incase you are seing data loss please log a case with CA Support.