Data Collector(s) stop SNMP polling thousands of devices in DX NetOps Performance Management
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Data Collector(s) stop SNMP polling thousands of devices in DX NetOps Performance Management

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Article ID: 94987

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

Management Lost status is being seen on many devices and the count continues to grow even though the devices are reachable via SNMP from the DC command line.  We can temporarily regain access to the devices by restarting the data collector (dcmd) service.

This may also be exhibited by devices with less polled items than expected.

Environment

All supported Performance Management releases.

Cause

In some environments ActiveMQ can loose stability over time.

In other situations there may be issues between the Data Aggregator and Data Collector where the Data Collector loses polling configuration for some devices and their items. As a result with the polling configuration missing some items, those items are no longer polled. Once this takes place, without a Stop/Start Polling cycle on select devices, or restart of both Data Aggregator and/or Data Collector(s) the Data Collector(s) won't know they have wrong polling configuration and won't seek to update it to correct the issue.

Resolution

Improvements to the environment and stability of the ActiveMQ service in addition to an upgraded release of ActiveMQ alleviates the Management Lost problem.  Please upgrade to the latest available DX NetOps Performance Management release.

All known instances of the incorrect Polling Configuration issue have been resolved in the latest DX NetOps Performance Management releases. Upgrade to resolve them.