SPC-OCA-10704: No permission connecting to domain. Ensure the .hostrc file permits this host to connect.
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SPC-OCA-10704: No permission connecting to domain. Ensure the .hostrc file permits this host to connect.

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Article ID: 94951

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Updated On:

Products

CA Spectrum

Issue/Introduction

After upgrading to Performance Center 3.2, we see what appear to be incorrect netQOS integration event poller exceptions, in the Spectrum tomcat log. 

SPC-OCA-10704: No permission connecting to domain <landscape>. Ensure the .hostrc file permits this host to connect. 

What is the cause of this?

Environment

Any version of Spectrum integrates with CAPM.

Cause

There are various situations, that can cause this error:

1. the hostrc file is badly populated.
2. The OneClick user does not have the correct permission, to access the SpectroSERVER.
3. A disconnect between the OneClick server and the SpectroSERVER or Archive Manager.
4. SpectroSERVER is busy and dropped the CORBA request

We need only be concerned, when this error repeats itself constantly and we see that events are not updating in OneClick, from the landscape in question.

To understand what is causing it, we need to enable debug on both the SpectroSERVER and the OneClick server and await a reoccurrence of the error.
 

Resolution

In this example, it is happening a couple of times per day, and the events are up to date.  This is typically caused by temporary disconnects, so is not a problem, that needs to be investigated as it can be safely ignored.  The error message will be altered in a future release, to be less specific, and reflect the various possible causes.

Additional Information

In case you see the continuous message

How to enable Debug FOR the SpectroSERVER: 
-------------------------------------- 
Goto to the VNM model in the OneClick console
   -> information tab
       -> dynamic debugging 
             -> enable the logging on "SpectroSERVER CORBA Communication" and "General SpectroSERVER Communication". 

Also enable moot trace and cobra trace

Enable tomcat debug 
----------------------------------------- 
From the OC web admin page -> Admin tab -> debug -> web server debug runtime 

Please enable the following and apply: 

1.ModelDomainList 
2.EventDomainList 
3.SnmpDomainList 

Once the problem has reoccurred, collect the tomcat log and the VNM.out, which are belonged to same time interval and upload for analysis, if needed.
Turn off the debug.