Service Manager Outage History is missing in OneClick
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Service Manager Outage History is missing in OneClick

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Article ID: 94748

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Updated On:

Products

CA Spectrum

Issue/Introduction

Service Manager Outage History is missing in OneClick 

Environment

Any version of Spectrum

Cause

Enabled the "Event Domain List" and "Event Data Model" debug module in OneClick:

1. Log into the OneClick web page as an ADMIN user

2. Click on the Administration link

3. Click on the Debugging link

4. Click on the Web Server Debug Page (Runtime) link

5. Enable the "Event Domain List" and "Event Data Model" debug modules

6. Scroll to the bottom of the page and set the Desired Level to MAX and click on the Apply button

7. Review the $SPECROOT/tomcat/logs/stdout.log (Windows) or catalina.out (Linux) file for entries similar to the following:


Apr 23, 2018 11:03:57.649 (EventUpdates@slm) (SLM_STAT_EVENT) - dataUpdated: starting with state = 

DomainEventState: 
domain ID = 0x100000 
histUpdateOngoing = true 
lastEventTime = 1523603683 
syncTime = null 
queue size = 126 
firstEventTime = null 
trackingModelsWithNoEvents = false 

Apr 23, 2018 11:03:57.649 (EventUpdates@slm) (SLM_STAT_EVENT) - dataUpdated: queuing real-time events while waiting for historical update


If histUpdateOngoing is true, then all the events are in a queue. 

Resolution

Restart the OneClick server. Enable the same debugging to ensure the error above is no longer seen.