Service Catalog - Alert Messages - Show Summary blank popup
book
Article ID: 93484
calendar_today
Updated On:
Products
CA Service CatalogCA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
The button "Show Summary" under Alert Messages produce a blank popup. The problem seems only exist under IE 11 - under Chrome it works.
The issue: 1. Start the IE11 browser 2a. Login to the SC-UI with spadmin userid 2b. Home/Messages>Alerts 3. Hit 'filter alerts' 3a. In the filter-popup: 3b. In properties, click on Date/Time 3c. In operators, click on >= 3d. In the calendar, select 1/1/2010 3e. Hit 'Add Condition' 3f. In operators, click on <= 3g. In the calendar, select 1/1/2019 3h. Hit 'Add Condition' 3i. Hit 'Filter' and then hit 'Close'. >>> The list of alerts(1) appears. 4. From within the list, click on the 'summary' icon. >> The summary popup appears. >> In Chrome this is okay, in IE11, the popup is blank.
Environment
Windows, running IE11 and Chrome.
Cause
Debugging: Set the IE11 browser in (F12) debug mode/debugger mode. And while opening the summary for an alert, I get this returned: SCRIPT438: Object doesn't support property or method 'createStyleSheet' File: wpf, Line: 331, Column: 11
Then in 'google' for this message "Object doesn't support property or method 'createStyleSheet'", I found: "In "emulation mode" or older versions of IE it works."
Resolution
The Solution: Resolve the issue in the following way: 1. Start the IE11 browser 2. Open the Tools menu and select Compatibility View Settings. 3. I then added my server name (winx64) (hit the 'Add' button). 4. I checked both settings at the bottom. 5. And 'Close' the popup. 6. Refresh the browser(F5) and >> Open the summary which then shows properly.