Agent 11.4 plugin installer failed - schema.jar is not a file in the agent directory. It cannot be backed up.
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Agent 11.4 plugin installer failed - schema.jar is not a file in the agent directory. It cannot be backed up.

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Article ID: 93285

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Updated On:

Products

Workload Automation Agent

Issue/Introduction

When I attempt to install Agent plugin on top of CA Workload Automation Agent 11.4, the agent plug-in installation fails with a message like;
Installer failed: F:\Program Files\CA\WA Agent/jars/ext/axis-schema.jar is not a file in the agent directory. It cannot be backed up.
 

Environment

CA Workload Automation Agent 11.4

Cause

The Agent 11.4 PluginInstaller fails while backing up the files.

Resolution

There is a known issue in the CA Workload Automation Agent 11.4 documentation where plug-in installation fails when the Agent installation directory is specified As ".";
 

Plug-in Installation Fails When the Agent Installation Directory is Specified As "."

When you use the PluginInstaller to install a plug-in, if the agent installation directory is specified as "." instead of a full path (for example, “./PluginInstaller ./appservices.pak .”), the PluginInstaller fails while backing up the files with a message like:

… is not a file in the agent directory. It cannot be backed up.

To work around this issue, specify the full path of the agent directory, for example:

./PluginInstaller ./appservices.pak /opt/CA/WA_AGENT
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If the work around fails with the same message, open a Support Case with CA for a Fix for the pluginInstaller issue.