Vertica version mismatch when starting node
search cancel

Vertica version mismatch when starting node

book

Article ID: 93131

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

When starting the vertica node we see a "version mismatch" message.  When we run ​/opt/vertica/bin/admintools -t list_allnodes we see the follow:


/opt/vertica/bin/admintools -t list_allnodes 
Enter password for [email protected](3 attempts left): 
Node | Host | State | Version | DB 
-------------------+---------------+-------+-----------------+-------- 
v_drdata_node0001 | xxx.xx.xx.xxx| UP | unavailable | drdata 
v_drdata_node0002 | xxx.xx.xx.xxx| DOWN | vertica-8.1.0.4 | drdata 
v_drdata_node0003 | xxx.xx.xx.xxx| UP | unavailable | drdata 

Environment

Any version of CAPM

Cause

Message set up in /etc/issue caused this problem

Resolution

Remove the message in /etc/issue then log out and in again.  When you run opt/vertica/bin/admintools -t list_allnodes  you should now see versions for all nodes

Additional Information

If the issue persists check /etc/motd, /etc/banner, and /etc/ssh/banner files and remove any content.