User Is Locked in CA API Developer Portal 4.x and Newer
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User Is Locked in CA API Developer Portal 4.x and Newer

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Article ID: 9304

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Updated On:

Products

CA API Developer Portal CA API Gateway

Issue/Introduction

The user account in the CA API Developer Portal 4.x ("Portal") is locked and cannot login through SSH into the Portal server.

Environment

CA API Developer Portal 4.x and newer.

Cause

The user account is locked because of multiple password attempt failures.

Resolution

Unlocking the account

If the portal password is unknown and the account is locked due to too many failed authentication attempts then the following error message may appear: Account locked due to 5 failed logins. If this error occurs then the portal account will need to be unlocked.

1. Connect to the CA API Portal via a serial cable or direct console access.
2. Restart the CA API Portal appliance.
3. Next, select your Kernel version from the grub menu item and press e key to edit the first boot option. Now use the Down arrow key to find the kernel line (starts with “linux16“), then change the argument ro to  rw init=/sysroot/bin/sh as shown in the screenshot below.



4. Once you have finished the task in the previous step, press Ctrl-X or F10 to boot into single-user mode (access an emergency shell).
5. Now mount root (/) filesystem using the following command.

#mount –o remount,rw /sysroot

#chroot /sysroot

6. Reset the portal user account

# faillock --user portal --reset

7. Once you are done, reboot the system using this command.

           # reboot -f

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