Service Catalog integration with CA Service Desk Manager 17.1 fails
search cancel

Service Catalog integration with CA Service Desk Manager 17.1 fails

book

Article ID: 92883

calendar_today

Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When testing the integration from Service Catalog to Service Desk Manager 17.1, the application fails showing:

Error occurred while trying to connect. Please check your configuration and server availability

view.log shows:

TRACE [http-bio-8080-exec-22] [Configuration] In queryConfigurationObjects for domain/groupName : INSTALLED_DEFAULT/servicedesk
TRACE [http-bio-8080-exec-22] [AbstractWebserviceManager] WS URL Full Address = http://<service_desk_hostname>:8080/axis/services/USD_R11_WebService
TRACE [http-bio-8080-exec-22] [AbstractWebserviceManager] WS Class Name= com.ca.usm.webservices.ServiceDeskWebserviceManager
TRACE [http-bio-8080-exec-22] [AbstractWebserviceManager] pki:CASM_POLICY:C:/Program Files/CA/Service Catalog\CASM_POLICY.p12:CASMAdmin:3:15
TRACE [http-bio-8080-exec-22] [ServiceDeskWebserviceManager] begin:loginMethodPki
TRACE [http-bio-8080-exec-22] [ServiceDeskWebserviceManager] begin:loginMethodPki-2:http://<service_desk_hostname>:8080/axis/services/USD_R11_WebService




When clicking on Launch, it shows up 404 HTTP error and creates the SDM URL without context. Only http://<service_desk_hostname>:8080/

Environment

Service Catalog 14.1 and later
Service Desk Manager 17.1

Cause

The "Preview Session Can Update Database" option is checked for the user being used as contact proxy in the policy used for the integration between Service Catalog and Service Desk Manager.
 

Resolution

1. Take note of the policy being used in the integration from CA Service Catalog: Administration > Configuration > CA Service Desk Manager > See the Policy Code.
2. Log into Service Desk Manager > Administration > SOAP Web Services Policy > Open the policy being used (step above) > Click on the Proxy Contact > Take note of the Access Type
3. Open the Access Type > Go to 2. Web Screen Painter > Un-check "Preview Session Can Update Database" > Save Changes.