In the Automic Web Interface a Task with status "Waiting for start time" cannot be started via Process Monitoring
search cancel

In the Automic Web Interface a Task with status "Waiting for start time" cannot be started via Process Monitoring

book

Article ID: 92771

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Tasks that are assigned an Earliest Start Time in a workflow and are therefore visible with the status "Waiting for start time" in the Process Monitoring view cannot be started via the context menu entry "Modify Task". 
When selecting this option an error message pop-up appears: 

 
Runtime error in object' XEXECUTEONCE (GET)', line' 00087'. No valid timestamp'' (YYYYY-MM-DD HH: MM: SS) 

Below are some screenshots which illustrate how the error can be raised:

<Please see attached file for image>

User-added image

<Please see attached file for image>

User-added image

<Please see attached file for image>

User-added image

<Please see attached file for image>

User-added image

Environment

N/A

Cause

A Time conversion problem causes Modify Task process to fail.
A timestamp value was transformed from UTC to the user-specific time-zone. This transformation is now only attempted if the timestamp is not empty.

Resolution

Update to a fixed version listed below or a newer version if available.

Component(s):
Automic Web Interface (UI)

Fixed Version(s):
Automic Web Interface 12.1.2 - planned release date: 2018-05-23

Attachments

1558703152241000092771_sktwi1f5rjvs16l7s.png get_app
1558703150264000092771_sktwi1f5rjvs16l7r.png get_app
1558703148510000092771_sktwi1f5rjvs16l7q.png get_app
1558703146357000092771_sktwi1f5rjvs16l7p.png get_app