In the Automic Web Interface a Task with status "Waiting for start time" cannot be started via Process Monitoring
book
Article ID: 92771
calendar_today
Updated On:
Products
CA Automic Workload Automation - Automation Engine
Issue/Introduction
Tasks that are assigned an Earliest Start Time in a workflow and are therefore visible with the status "Waiting for start time" in the Process Monitoring view cannot be started via the context menu entry "Modify Task". When selecting this option an error message pop-up appears:
Runtime error in object' XEXECUTEONCE (GET)', line' 00087'. No valid timestamp'' (YYYYY-MM-DD HH: MM: SS)
Below are some screenshots which illustrate how the error can be raised:
<Please see attached file for image>
<Please see attached file for image>
<Please see attached file for image>
<Please see attached file for image>
Environment
N/A
Cause
A Time conversion problem causes Modify Task process to fail. A timestamp value was transformed from UTC to the user-specific time-zone. This transformation is now only attempted if the timestamp is not empty.
Resolution
Update to a fixed version listed below or a newer version if available.