Special Characters in Service Catalog
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Special Characters in Service Catalog

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Article ID: 9274

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Updated On:

Products

CA Service Catalog

Issue/Introduction

Problems in CA Service Catalog with Special Characters like accents and others would need to be addressed

Environment

Windows, running Service Catalog 12.9 and above.

Cause

Tomcat URIEncoding is not in the "Connector" tag

Resolution

1. Go to USM_HOME\view\conf\server.xml

2. Locate the Connector tag being used (it could be SSL or non SSL connector)

3. Open the file with e.g. Notepad and add URIEncoding="UTF-8" to the Connector tag.

4. Save the changes

5. Restart Services and clear browser cache:
5a Stop the CA Service Catalog services(Accounting and Catalog).

5b Empty/clear the %USM_HOME%\view\translets folder.

5c (re)move the %USM_HOME%\logs\*.log files.

5d Clear the browser-cache.

5e Start the CA Service Catalog services(Accounting and Catalog).

Additional Information

There is a known issue with special characters present in named tenants that is addressed in 17.3 RU18

Configure CA Service Catalog to Use Secure Socket Layer