Unable to download attmnt with some Access Type after 14.1.04.1
search cancel

Unable to download attmnt with some Access Type after 14.1.04.1

book

Article ID: 92623

calendar_today

Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

After the installation of Service Management 14.1.04.1 on  SDM 14.1. The attachment download is not possible for particular Access Types. The following message appears in stdlog:


04/05 09:41:01.48 SRV boplgin 2868 SEVERE_ERROR bpmessage.c 779 BPMessage::operator[3]: index out-of-bounds max = 1
04/05 09:41:01.48 SRV boplgin 2868 SIGNIFICANT bpmessage.c 783 BPMessage [User ServiceDesk]
04/05 09:41:01.48 SRV boplgin 2868 SIGNIFICANT bpmessage.c 783 {
04/05 09:41:01.48 SRV boplgin 2868 SIGNIFICANT bpmessage.c 783 method = get_artifact
04/05 09:41:01.48 SRV boplgin 2868 SIGNIFICANT bpmessage.c 783 arg 0 = (string)cnt:1C4E8309D2C82E46816EDC137BF39507
04/05 09:41:01.48 SRV boplgin 2868 SIGNIFICANT bpmessage.c 783 arg 1 = (integer)328309709
04/05 09:41:01.48 SRV boplgin 2868 SIGNIFICANT bpmessage.c 783 reply object = @.web:local.yjFAAA (not refcounted)
...
09:41:01.48 GRA-BKG01 boplgin 2868 ERROR bplaccess.c 4438 AHD04042:Login failed for userid (ServiceDesk); login timed out

Environment

All platforms

Cause

No Default Role are assigned automatically

Resolution

Assign Roles for

Reporting Role REST

Web Service API Role

SOAP Web Service

API Role Command Line Utility

Role for the Access type