Not able to manage ADS accounts or open ADS Explore/Correlate page from Provisioning Manager
search cancel

Not able to manage ADS accounts or open ADS Explore/Correlate page from Provisioning Manager

book

Article ID: 9261

calendar_today

Updated On:

Products

CA Identity Manager

Issue/Introduction

Identity Manager is not able to change AD account password, it is not syncing or any other attribute is not being syncing with AD account

Environment

Identity Manager 14.x

Cause

From Provisioning Manager in ADS Properties page the password was set using the Update button, even do the problem still persist.

 

In the ADS log ../ProvisioningServe/logs/ADS folder we have the ADS log with the following error message:

ldap_simple_bind_s() .....ERROR: 49

    LdapGetLastError(): 49

    Error msg: Invalid Credentials

 

The account is located under correct OU/Container, and password was verified and it is correct.

Resolution

For some reason the Update button didn't update correctly the password, in this case use the etautil command below to force the update.

 

etautil -u SuperUserToLogin -p PasswordOfSuperUser update 'eTNamespaceName=ActiveDirectory' eTADSDirectory eTADSDirectoryName='Your_ADS_EndpointName' eTADSAuthPwd='The_Password' 

 

After that, close Provisioning Manager, and restart Provisioning Server service.