In CA Identity Manager brackets (<>) are not working in PX Policy SOAP calls
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In CA Identity Manager brackets (<>) are not working in PX Policy SOAP calls

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Article ID: 9259

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CLOUDMINDER ADVANCED AUTHENTICATION CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On

Issue/Introduction

A PX Policy that has HTML as part of a data element or action may experience problems with the special characters such as angle brackets (<>). You may run into an issue because HTML angle brackets get replaced with &#60; and &#62; respectively; this is normal and is understood by HTML. The problem is that the PX logic can't deal with these characters.  You'll get an error on running the PX stating that ('&' encountered' '<' expected).  

 

Also, if you are trying to add some HTML element, like <br> the email display the element instead of breaking the line.

 

Environment

Identity Manager 14.3 or higher

Cause

This is a bug in Identity Manager that was fixed in 14.1. If you are on a version lower than this you'll need to upgrade the product to resolve the problem. 

Resolution

The fix for this bug is a user-defined property called AllowHtmlTagsInPX, to use this functionality you'll have to add this property in your management console. Setting AllowHtmlTagsInPX to true will turn on the fix, and setting it to false will turn the fix off. 

The User Defined Properties are located under the CA Management Console -> Environments -> [your environment] -> Advanced Settings -> Miscellaneous.