Synchronization failure with Spectrum Infrastructure Manager
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Synchronization failure with Spectrum Infrastructure Manager

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Article ID: 92366

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration CA Spectrum

Issue/Introduction

Spectrum synchronization failed with CA Performance center with a timeout error.

Data source Spectrum Infrastructure Manager@xxxxxxxx did not respond to a sync request within the timeout interval. The problem is in the data source, not CAPC. Check the logs for the data source to determine why it did not respond. The following stack trace shows the context of the sync request: 
INFO | jvm 1 | 2018/04/12 10:15:34 | javax.xml.ws.WebServiceException: Could not send Message. 
INFO | jvm 1 | 2018/04/12 10:15:34 | at org.apache.cxf.jaxws.JaxWsClientProxy.invoke(JaxWsClientProxy.java:145) 
INFO | jvm 1 | 2018/04/12 10:15:34 | at com.sun.proxy.$Proxy104.pullRequest(Unknown Source) 
INFO | jvm 1 | 2018/04/12 10:15:34 | at com.ca.im.portal.api.services.datasource.ProductSync2WSProxyImpl.pullRequest(ProductSync2WSProxyImpl.java:69) 
INFO | jvm 1 | 2018/04/12 10:15:34 | at com.ca.im.portal.dm.productsync.DataSourcePull.pullSync(DataSourcePull.java:130) 
INFO | jvm 1 | 2018/04/12 10:15:34 | at com.ca.im.portal.dm.productsync.DataSourcePullPhase.executeInternal(DataSourcePullPhase.java:37) 
INFO | jvm 1 | 2018/04/12 10:15:34 | at com.ca.im.portal.dm.productsync.DataSourceSyncPhase.execute(DataSourceSyncPhase.java:76) 
INFO | jvm 1 | 2018/04/12 10:15:34 | at com.ca.im.portal.dm.productsync.PullSyncPhaseTask.pullDataSource(PullSyncPhaseTask.java:103) 
INFO | jvm 1 | 2018/04/12 10:15:34 | at com.ca.im.portal.dm.productsync.PullSyncPhaseTask.execute(PullSyncPhaseTask.java:70) 
INFO | jvm 1 | 2018/04/12 10:15:34 | at com.ca.im.portal.dm.productsync.SyncPhaseExecutor$MakeDSSyncPhaseCallable$1.call(SyncPhaseExecutor.java:101) 
INFO | jvm 1 | 2018/04/12 10:15:34 | at com.ca.im.portal.dm.productsync.SyncPhaseExecutor$MakeDSSyncPhaseCallable$1.call(SyncPhaseExecutor.java:94) 
INFO | jvm 1 | 2018/04/12 10:15:34 | at java.util.concurrent.FutureTask.run(FutureTask.java:266) 
INFO | jvm 1 | 2018/04/12 10:15:34 | at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) 
INFO | jvm 1 | 2018/04/12 10:15:34 | at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) 
INFO | jvm 1 | 2018/04/12 10:15:34 | at java.lang.Thread.run(Thread.java:745) 
INFO | jvm 1 | 2018/04/12 10:15:34 | Caused by: java.net.SocketTimeoutException: SocketTimeoutException invoking https://xxxxxx:9443/axis2/services/ProductSync2WS: Read timed out

Environment

CA Performance Management 3.x
CA Spectrum 10.x
 

Cause

Spectrum oneclick server which is integrated with CA Performance center is not responding to the requests from CAPC in a timely manner. The spectrum oneclick server is possibly
undersized on resources. 

Resolution

Following are possible solutions :

a) Restart the Spectrum oneclick tomcat service 

You can start or stop the OneClick web server from a command prompt.

On Solaris or Linux, log in as root. Use the following commands:

 

  • To start the web server:

    <$SPECROOT>/tomcat/bin/startTomcat.sh
  • To stop the web server:

    <$SPECROOT>/tomcat/bin/stopTomcat.sh
  • To restart (stop, then start) the web server:

    <$SPECROOT>/tomcat/webapps/spectrum/restart.sh



To start or stop the OneClick web server on Windows, enter the following commands at a command prompt:


To start the web server:


  • C:\> net start spectrumtomcat
  • To stop the web server:

    C:\> net stop spectrumtomcat


b) Perform a full synchronization with the Spectrum oneclick server.


If the problem persists after the restart the following Spectrum OneClick fixes may be required

Spectrum 10.3.2 (without any BMP fixes) - Spectrum_10.03.02.D90e
Spectrum 10.3.2 (with 10.3.2_BMP_10.3.202) - 10.3.2_PTF_10.3.257

 

Additional Information

In case the problem persists please log a case with the support team.