Spectrum Report Manager (SRM) is not purging old data as configured
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Spectrum Report Manager (SRM) is not purging old data as configured

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Article ID: 92354

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

Spectrum Report Manager (SRM) is not purging old data as configured

The Data Retention Policy in the Administrator -> Report Manager -> Preferences page is set to Purge and the Data Retention Period (days) for Event Table is set to 120 days, but looking at the Archive Expert, the History (Days) is above 120 days.

Environment

CA Spectrum 21.2, 22.2

Cause

Possible wait timeout error

Resolution

Enable the following OneClick debugging:

1. Log into the OneClick SRM web pages as an ADMIN user

2. Click on the Administration link

3. Click on the Debugging link

4. Click on the Web Server Debug Page (Runtime) link

5. Find and enable the SRM - Tools - Archiver debug

6. Scroll to the bottom of the page and set the Desired Level to MAX and click the Apply button

At midnight, SRM will trigger the Archiver

7. Check the $SPECROOT/tomcat/logs/stdout.log (Windows) or catalina.out (Linux) file for the following error:

Apr 19, 2018 00:01:31.467 (CrystalOnlyUserManager) (SRMArchiverLog) - (ERROR) - Could not prune source event records 
Caused by: org.springframework.dao.CannotAcquireLockException: PreparedStatementCallback; SQL [DELETE FROM event WHERE time < ?]; Lock wait timeout exceeded; try restarting transaction; nested exception is java.sql.SQLException: Lock wait timeout exceeded; try restarting transaction

If found, please reference knowledge article 48179 "Errors seen in the catalina.out/stdout.log file halting processing of events on Spectrum Report Manager (SRM) server" for instructions on how to increase the lock wait timeout parameter.