In the Automic Web Interface the sorting of Agents by IP Address in the Administration View is not correct
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In the Automic Web Interface the sorting of Agents by IP Address in the Administration View is not correct

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Article ID: 92347

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

The sorting of the Agents by IP-Address (or Agent version) is not correct. There seems to be an issue when numbers have a different length - two vs. three digits. 

Example:

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User-added image

Environment

N/A

Cause

A problem has been fixed where alphabetical ordering is applied when sorting by IP or version in the Agents list, disregarding numerical order. Because the fields were considered as simple text, numeric information was not parsed correctly, resulting in situations such as "20" appearing before "100". Parsing now accounts for numeric values and sorts them accordingly.

Resolution

Update to a fix version listed below or a newer version if available.

Component(s):
Automic Web Interface (UI)

Fix Version(s):
Automation Engine 12.1.2 - planned release date: 2018-05-23

Attachments

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