Data Collector is not connecting
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Data Collector is not connecting

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Article ID: 9206

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

A Data Collector is showing as "Not Connected" in Performance Center console, even though the dcmd process is running and has been restarted

Environment

CA Performance Management, all versions

Cause

There is an issue with activeMQ, and restarting only the dcmd process may not resolve the issue

Resolution

1. Stop dcmd, as follows;
           On Red Hat 6.x    /etc/init.d/dcmd stop
           On Red Hat 7.x   systemctl stop dcmd or /opt/IMDataCollector/scripts/dcmd stop



2. Stop activeMQ, as follows;
           On Red Hat 6.x   /etc/init.d/activemq stop
           On Red Hat 7.x   systemctl stop activemq    or /opt/IMDataCollector/scripts/activemq stop



3. Delete or rename the "/opt/IMDataCollector/apache-karaf-2.4.3/data" folder (path may vary)



4. Start dcmd, as follows;
          On Red Hat 6.x    /etc/init.d/dcmd start  (this will also start activemq)
          On Red Hat 7.x    systemctl start dcmd  or /opt/IMDataCollector/scripts/dcmd start     (this will alos start activemq)



       



The Data Collector should now show as "Collecting Data" in the CA Performance Center console