APIM EPAgent Log Metric error "Data from plugin is invalid."
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APIM EPAgent Log Metric error "Data from plugin is invalid."

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Article ID: 91951

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Updated On:

Products

STARTER PACK-7 CA Application Performance Management Agent (APM / Wily / Introscope) INTROSCOPE CA Rapid App Security CA API Gateway

Issue/Introduction

With the APIM - EP Agent integration in place, seeing two different errors in EPAgent.log. 

1) 4/06/18 09:21:15 AM CDT [INFO] [EPAgent] Network Server processing connection from Socket[addr=/127.0.0.1,port=51044,localport=9090]. 
4/06/18 09:21:15 AM CDT [ERROR] [EPAgent] Metric data from plugin 'Client at Socket[addr=/127.0.0.1,port=51044,localport=9090]' is invalid:

2) 4/09/18 04:32:16 AM CDT [INFO] [EPAgent.EPAgent OPERATING_STATUS] Starting plugin 'OPERATING_STATUS'.  
4/09/18 04:32:16 AM CDT [ERROR] [EPAgent.EPAgent OPERATING_STATUS] [ stderr ] Can't load log handler "java.util.logging.FileHandler

Environment

APM 10.3 with APIM Gateway 9.2

Cause

     1) An invalid character from the Gateway to the EPAgent and it is dropping the metrics.
     On a prior case,learned that the URL having an & was the culprit .

  <param name="ATTR_Uri" value="http://www.tarr12a.com/calsc/am20/catalog/remoteoffice/v1/items?       root=cc92c7ad9_5d5987&recordCount=30&offSet=60&_=1523024039916"/>
     2) The file permissions of the SecureGateway logs folder: is incorrect.
 

Resolution

    
    1) Attach  APM_Traces_fixed_v3.zip.
   The fix that solved  this 
   Trace data is generated by scheduled job APM_Traces that runs every 15 seconds. This policy basically sends the output of the assertion "Get Latency Metrics" (Assertion Level). One of the elements in the xml output of this assertion is "param name="ATTR_Uri"". This element is child element of backend components. However, if the back-end call in the API has URL attributes, the trace output is malformed, as the URL parameters are not encoded. We corrected this by evaluating a regular expression and replacing the "&" characters with "&amp;" in the  attached policy. file.

The updated policy(APM_Traces_fixed_v3.xml) resolved the issue. 

2) 1) Change the rights of the SecureGateway logs folder:  
    chmod 775 /opt/SecureSpan/Gateway/config/logs  to eliminate the error  

 

Attachments

1558536285481APM_Traces_fixed_v3.zip get_app