RA Agent for Informatica is no receiving log files in Job run report
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RA Agent for Informatica is no receiving log files in Job run report

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Article ID: 91880

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

RA Agent for Informatica is no receiving log files in Job run report after Informatica was upgraded from v9.6 to v10.1.

The jobs run properly but the Automic Agent set the job status to "failed" when it doesn't receive the reports from the job run. The error is shown below: 

2018-03-29 15:44:02 Connected to repository 
2018-03-29 15:44:02 Parameters prepared 
2018-03-29 15:44:02 New Workflow Starting.... 
2018-03-29 15:44:03 runID after startWorkFlow: 366301 
2018-03-29 15:44:04 Informatica Workflow Started on remote site. runID: 10163762 runInstanceName:10163762 remote runID:366301 pmcmd version:[10.1.1 HotFix2], build [1507.1025], AIX 64-bit WF log file:/work/inform/WorkflowLogs/Wfl_test_Connection.log 
2018-03-29 15:44:04 Waiting for Informatica job to finish on remote site. runID: 10163762 remote runID:366301 
2018-03-29 15:44:10 Informatica Workflow job finished on remote site. Prepare to fetch log files. runID:10163762 remote runID:366301 
2018-03-29 15:44:10 Error retrieving Workflow log file, runid: 366301 
2018-03-29 15:44:10 Stderr: /app/inform10/server/bin/infacmd.sh[29]: /app/inform10/isp/bin/infacmd.sh: not found. 
2018-03-29 15:44:40 Error retrieving Workflow log file, runid: 366301 
2018-03-29 15:44:40 Stderr: /app/inform10/server/bin/infacmd.sh[29]: /app/inform10/isp/bin/infacmd.sh: not found. 
2018-03-29 15:45:10 Error retrieving Workflow log file, runid: 366301 
2018-03-29 15:45:10 Stderr: /app/inform10/server/bin/infacmd.sh[29]: /app/inform10/isp/bin/infacmd.sh: not found. 
2018-03-29 15:45:40 Error retrieving Workflow log file, runid: 366301 
2018-03-29 15:45:40 Stderr: /app/inform10/server/bin/infacmd.sh[29]: /app/inform10/isp/bin/infacmd.sh: not found. 
2018-03-29 15:46:15 WorkFlow executed Session/Task/Worklet count: 0. Is Run Instance Name Used? false 
2018-03-29 15:46:15 ** WorkFlow error message is: Could not retrieve Workflow Log after 3 retries 
2018-03-29 15:46:15 Informatica Workflow Job runID:10163762 remote runID:366301 ended with remote status:0 Succeeded 


The RA Informatica JOB terminates in INFORMATICA but ends with Code 2:

20180329/154615.590 - Informatica Workflow Job runID:10163762 remote runID:366301 ended with remote status:0 Succeeded 
20180329/154615.617 - U00029001 Report '10162888' ended normally. 
20180329/154615.642 - U02000009 Job '<job_name>' with RunID '10163762' ended with return code '2'. 
20180329/154615.654 - U00029000 Report '10162904' for file '../temp//WK_Wfl_test_Connection_366301_Wfl_test_Connection.log' has been started. 
20180329/154615.658 - U00029001 Report '10162904' ended normally. 
20180329/154615.683 - U02001026 Job '<job_name>' with RunID '10163762' has been removed from the job table. 
20180329/154615.697 - U00029000 Report '10162905' for file '/app/automic/ae12/Agents/informatica/bin/../temp/OAAWGHDY.TXT' has been started. 
20180329/154615.717 - U00029001 Report '10162905' ended normally. 


It is important to know that even though jobs aborts in this case the agent is able to connect to INFORMATICA and to list jobs present on this database.


 

Environment

Release:
Component: AAUTEN

Cause

The problem is prone to come from profile settings of the submission user that triggers the job. These topic should be verified 
 

Resolution

Setting the following environment variables for the OS user that runs the Informatica agent as shown in the examples below.

For UNIX/Linux:



INFA_HOME=/informatica/9.x



INFA_DOMAINS_FILE=$INFA_HOME/domains.infa



For Windows:



INFA_HOME=C:\informatica\9.x



INFA_DOMAINS_FILE=%INFA_HOME%\domains.infa


Setting the library path variable for the user that runs the Informatica agent as shown in the examples below.

For UNIX/Linux:



LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$INFA_HOME/server/bin



For AIX:



LIBPATH=$LIBPATH:$INFA_HOME/server/bin
 


More details to environment configuration are listed here in this documentation:

https://docs.automic.com/documentation/webhelp/english/AWA/12.1/RA_INFORMATICA/5.0/Agent%20Guide/help_en.htm#RA/Informatica/AWI/Informatica_Administration.htm%3FTocPath%3DWorking%2520with%2520the%2520Informatica%2520Agent%2520Integration%7C_____1