DX UIM administrator password reset scenarios and options
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DX UIM administrator password reset scenarios and options

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Article ID: 91865

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

A new UIM administrator may take over the monitoring infrastructure and tasks but the previous admin did not share the admin password or document it somewhere, nor do they remember it.

Therefore, what are the steps to reset it?

Environment

  • Release: Any version
  • Infrastructure Manager (IM)
    • IM current version for CU must be used
  • Component: UIMHUB
  • hub

Cause

  • Admin password unknown/forgotten
  • Admin password undocumented

 

Resolution

Password requirements

  • Minimum of 8 characters, max 256
  • 1 UPPER case letter
  • 1 lower case letter
  • 1 special character
  • 1 digit
  • May not contain the username


Scenario 1: Only one hub (Open a case with Support)

  1. Backup $NIMROOT\hub\security.cfg file
  2. Open Windows Services and Stop the Nimsoft Robot Watcher Service
  3. Edit $NIMROOT\hub\security.cfg file as follows:

    • Go to <Users> section
    • Change the password field to the following string: <Contact Broadcom UIM support for assistance with this step.> They will input the string, log you into IM and have you change the admin password to a 'known' string.
  4. In the Services window, rt-Click and Start the Nimsoft Robot Watcher Service

Now, you should be able to login with the user and password

Scenario 2: Multiple hubs

  1. Either shutdown other hubs if possible or block access from remote hubs to the primary or the hub where you are changing the user password.

    If you do not, by design the remote hubs will try to sync-overwrite the security.cfg file while you are changing the password.

    You can block remote hubs either using firewall to block incoming 48002/tcp (if only direct hubs/non-tunneled hubs are involved) or blocking the tunnel server port (default is 48003/tcp).

  2. Once communication from/to remote hubs have been blocked, then follow the steps described in Scenario 1.

Scenario 3: Hard Reset (for all hubs)

  1. Close Infrastructure Manager (IM)
  2. Stop the Nimbus Robot Watcher Service on all hubs
  3. On the Primary hub machine backup the security files to a different folder, then remove the security.* files
    - security.cfg
    - security.bak
    - security.dta
  4. Start the Nimbus Robot Watcher Service on the Primary hub
  5. Open the Infrastructure Manager
  6. You will be prompted to enter the Password and the Domain
  7. Add the Domain IP / name
  8. Click OK
  9. You will be prompted to enter a password
  10. Enter a new password and click OK
  11. You should be able to access the Infrastructure Manager (IM)
  12. Start the Nimbus Robot Watcher Service on the other hubs

Additional Information

Lab or Non-Prod, Test/DEV environments
If you are already logged in or you know the current admin password, you can simply:

  1. Change the password in IM via Security->Change Password or via User Administration.
  2. Double-click on the administrator user to open the dialog window
  3. Set the password
  4. Click Ok.
  5. Close the User Administration window to save the change.
  6. Logout
  7. Login


Note that if you change the UIM administrator user password you will need to share it with any other UIM administrators that access the Infrastructure Manager (IM), Operator Console (OC), Admin Console (AC), or UIMAPI, so they can login as the UIM administrator.