CA Performance Management (CAPM) Data Aggregator (DA) or Data Collector (DC) fails to start properly with "Error: Unable to update instance pid..."
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CA Performance Management (CAPM) Data Aggregator (DA) or Data Collector (DC) fails to start properly with "Error: Unable to update instance pid..."

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Article ID: 9183

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

When the DA or DC is started, it fails to synchronise and come online and instead throws an error similar to the following in the log file - <HOME_IMDataAggregator>/apache-karaf-2.4.3/data/karaf.out;

Unable to update instance pid: Unable to find root instance in /opt/CA/IMDataAggregator/apache-karaf-2.4.3/instances/instance.properties 

 

Environment

DX NetOps CAPM 20.2 and later

Cause

This error indicates that the configuration that the DA is trying to start with conflicts with configuration of a previous running instance that was not cleared properly when it was shutdown.

Resolution

First shutdown any running instances of the DA and the ActiveMQ;

service dadaemon stop

service activemq stop

Then, delete the DA data sub-directory under the apache-karaf directory:

<HOME_IMDataAggregator>/apache-karaf-<VERSION>/data

For example;

cd  /opt/CA/IMDataAggregator/apache-karaf-2.4.3

rm -rf  /opt/CA/IMDataAggregator/apache-karaf-2.4.3/data 

Then restart the dadaemon.   Activemq will automatically get started when dadaemon starts

NOTE: Use the rm -r command with caution as this will recursively delete all directories specified and their contents.

Additional Information

How to properly restart the DX NetOps Performance Management environment