APM Team Center not showing data. Getting "Maximum number of metrics exceeded" message.
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APM Team Center not showing data. Getting "Maximum number of metrics exceeded" message.

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Article ID: 9134

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Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) INTROSCOPE

Issue/Introduction

After login through APM Team Center, page shows "Maximum number of metrics exceeded"

Environment

APM 10.x

Cause

  The number of cards are clamped when there are too many to drill down or filter.  This indicates that the environment has too many cards.

 

Resolution

Workaround Scenario 1 - Environment without APM Team Center Master



1- Open the file "IntroscopeEnterpriseManager.properties" from your MOM



2- Add the below rows at the end of the file:



introscope.apmserver.atc.landing.historical.clamp.size=200
introscope.apmserver.atc.landing.clamp.size=1500



3- Save the file "IntroscopeEnterpriseManager.properties".



4- Restart your MOM.



 



Workaround Scenario 2 - Environment with APM Team Center Master



1- Open the file "IntroscopeEnterpriseManager.properties" for each MOM that are connected to the APM Team Center Master, including the APM Team Center Master EM file.



2- Add the below rows at the end of the file:



introscope.apmserver.atc.landing.historical.clamp.size=200
introscope.apmserver.atc.landing.clamp.size=1500



3- Save the file "IntroscopeEnterpriseManager.properties".



4- Restart all MOM and APM Team Center master EMs and Webview.