Resolving Attribute ID Conflicts
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Resolving Attribute ID Conflicts

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Article ID: 9069

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

While managing MIBs in Spectrum's OneClick MIB Tools utility, you may come across a conflict showing in the Attribute ID field. 

Environment

Platform Independant

Cause

This may happen if attributes are mapped on separate servers prior to the catalog being synced, or if there is a communication issue between servers when the catalog is synced. 

Resolution

The resolution is to manually sync the Spectrum Database Catalog across all DSS servers. 

To resolve the attribute ID conflict: 

1. Select the landscape that will be the master catalog (this is typically the MLS catalog). On this chosen Server, run the following from the /SS directory: 

../SS-Tools/SSdbsave -c <filename>.SSdb 

- the -c flag indicates the export/import of the catalog, which contains the information on model types and attributes 

2. Then copy that SSdb file to the other distributed SpectroSERVERs and on those servers from the /SS directory, run: 

../SS-Tools/SSdbload -c <filename>.SSdb 

 

** NOTE: be sure to run these commands from the <SPECROOT>/SS directory 

Additional Information

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