VSX CPU usages show "0" for a Checkpoint Appliance 13500
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VSX CPU usages show "0" for a Checkpoint Appliance 13500

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Article ID: 9056

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Updated On:

Products

CA Spectrum

Issue/Introduction


After discovered a Checkpoint Appliance 13500 device on OneClick, go to the "Information" tab of each VSX, you might find VSX CPU usages are all "0" under CheckPoint Firewall.

 

Cause


Spectrum polls vsxStatusCpuUsageTable (1.3.6.1.4.1.2620.1.16.22.2) in the device MIB to popular VSX CPU usage table. This is to show usage for all the Virtual systems of a CheckPoint device.

Resolution


Please collect the device SNMP walk file to check the value of vsxStatusCpuUsageTable (1.3.6.1.4.1.2620.1.16.22.2). If the device SNMP walk file doesn't have
  any entries for this OID or the value returns 0, this means the device is not sending any data or sending incorrect data for the VSX CPU usage. 



There is a known issue for Checkpoint that SNMP query for CPU usage by each Virtual System (OID 1.3.6.1.4.1.2620.1.16.22.2) returns 0 (zero) values. Please
  provide this CheckPoint link to the customer in order to contact the hardware vendor to get the fix for this problem.



https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solutionid=sk102434



Alternatively, there is a workaround for this in Spectrum. We can use Performance tab of each virtual system, which reads VSX CPU usage for all the CPU instances from HOST-RESOURCE-MIB [hrProcessorLoad 1.3.6.1.2.1.25.3.3.1.2] and populate to the graph.