Symptoms
Jobs are stuck in status 'Waiting for Host'.
Agent shows as inactive in System Overview.
Agent shows as active in Service Manager Dialog.
Agent shows as disconnected in Messages Window.
Investigation
File needed for analysis:
Logfile for the agent after the error has occurred.
In viewing the agent logfile there will be versions of the following lines:
U2000072 Connection to system 'XXX' initiated.
U2000019 The Server answers from system 'YYY'. Disconnecting again.
(XXX and YYY refer to any different system names)
Cause
The system named defined in the Agent .ini file does not match the system name defined in ucsrv.ini.
Resolution
Modify the Agent .ini file (ex.: UCXJWX6.ini) to match the system name as defined in ucsrv.ini.
The specific lines are:
Agent .ini file: system=XXXX
UCSrv.ini: system=XXXX