Symptoms
All new jobs submitted or updated go to a QUEUED status and are not being processed. You see the following errors in the RmiServer logs:
ErrorMsg: AwE-5001 Database Query Error (9/9/13 5:28 PM)
Details: aw2.check_launched_jobs
jdbc:oracle:thin:@us225.company.com:1521:apworxiq:APPWORX
java.sql.SQLException: ORA-06502: PL/SQL: numeric or value error: character to number conversion error
ORA-06512: at "APPWORX.AW2", line 245
ORA-06512: at line 1
Cause
This exception stops the timer thread from any further processing, so no aw_launch_job's are run (meaning no new jobs submitted/updated).
Troubleshooting
Need to investigate what this procedure returns, how it is defined in your Oracle instance, and how it could have caused a numeric conversion error.
Therefore, using the above example we can see that it was failing on a procedure within the aw2.check_launched_jobs procedure so we would do the following:
1) From the AM Client go to the Database Browser
2) Select the Procedures Tab
3) Select Packages --> AW2 --> CHECK_LAUNCHED_JOBS
4) You should see a row similar to this:
# ARGUMENT_NAME IN_OUT Data Type Default
0 IN
If you see something different in this table, you should contact Automic support to further troubleshoot this issue.