A Java heap space error message is preventing jobs from running.
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A Java heap space error message is preventing jobs from running.

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Article ID: 90462

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

A Java heap space error message is preventing jobs from running.

Environment

Release: AAMOS499000-8.0-Automic Applications Manager-OS400 Agent
Component:

Resolution

Symptoms

Jobs fail to process due to a "Job ##### has a parentjobid but getChain() has no value" error message. 

Note: A java.lang.OutOfMemoryError: Java heap space" error will also appear, but it is a red herring. Increasing Java memory will not have an impact. The reason the heap error occurred, is because the "job ##### … error is consuming resources."


Cause

This issue is normally seen if jobs enter the history with a bad status value. The most common reason for this is if jobs are deleted from the backlog via SQL or other means. We strongly recommend that you do NOT remove jobs from the backlog by deleting rows directly from the table through SQL*Plus.


Troubleshooting

Gather and examine the RmiServer debug logs.


Solution

Run the SQL statement below to confirm there are jobs containing a bad status value in the history records:

select count(*), so_status_name from so_job_history
where so_status_name in('INITIATED','RUNNING','STAGED','STAGED_PW','QUEUE WAIT','PRED WT HOLD','PRED WAIT','LAUNCH ERROR','KILLING','DATE PENDING','CONDITN WAIT','AGENT WAIT')
group by so_status_name, so_status
order by 2;

If  anything is returned, ensure that all of the Applications Manager processes are stopped and then run the SQL statements below to correctly set the status for these jobs:

update so_job_history set so_status=32, so_status_name='FINISHED'
where so_status_name in ('INITIATED','RUNNING','STAGED','STAGED_PW','QUEUE WAIT','PRED WT HOLD','PRED WAIT','LAUNCH ERROR',
'KILLING','DATE PENDING','CONDITN WAIT','AGENT WAIT');
commit;