Symptoms
Cancelling an Informatica job in OM8/v9/v10 shows the job as aborted in Informatica but seems to hang in Automic's OM8/v9/v10.
Cause
When we stop an Informatica Workflow job from Automic, we issue a pmcmd stopworkflow command and set the status to Aborted. If the Informatica job is canceled, you can see the kill command in the Report and the status in the messages window in OM8/v9/v10. After that Automic gathers workflowdetails and any output files as specified in their job definition. The job stays in the Activities window until the transfers are complete. If it takes a long time for these transfers to complete the Informatica job may appear to be hung.
Troubleshooting
If the Informatica job remains in the Activities windows for a prolonged period of time, it may be that it is having trouble retrieving the details and more specifically the output transfers. Request the following information:Example of In-house Output Transfer Test Results for Comparison
This was done with AE v9, RA Informatica Agent 3.1.1, and Informatica 9.5.1. We switched on the Always output transfer option for one of the larger Informatica WorkFlow jobs (it has close to 100 session tasks). That means it will transfer every output file for every session.
Stop command sent from Automic at: 23:04:48
End time from Informatica is: 23:04:54
End time in Automic: 23:06:44
Same Job using the Never output option. This only transfers the WF log and Report. It's a difference of transferring 2 files versus close to 100:
Stop command sent from Automic at: 23:26:15
End time from Informatica is: 23:26:22
End time in Automic : 23:26:30
This end time will actually be improved further in the next version of the Informatica RA Agent (newer than v3.1.1) when the Never option is selected.