Symptoms
Using IE 8 or later
Attempting to load the ECC Login page and the page never loads.
Able to load the Tomcat Admin page, so we know there's no issue connecting to the Server on port 8080.
Cause
In most cases, Compatibility Mode is turned on for Intranet Sites. The ECC is built for IE 9, so if compatibility mode is turned on, IE tries to load it as a IE 8 page and is unable to.
Resolution
In the Browser Window:
Press Alt > Tools > Compatibility View Settings
uncheck 'Display * in compatibility View'