ClearView Studio and ClearView Admin hang in Automic - Logo when Java SDK 1.7 is used
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ClearView Studio and ClearView Admin hang in Automic - Logo when Java SDK 1.7 is used

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Article ID: 90286

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

ClearView Studio and ClearView Admin hang in Automic - Logo when Java SDK 1.7 is used

Environment

Release: AOATAM99000-9.0-Automic-One Automation Tools-Application Manager
Component:

Resolution

Symptoms

Describe symptoms here

When having Java 1.7 installed ClearView Studio and ClearView Admin hang when starting it while displaying Automic-Logo, can be terminated in windows tasklist.


Cause

This is caused by having Java 1.7 installed, either installed (or updated) Java 1.7 when ClearView Studio and ClearView Admin was already installed, or ClearView Studio was installed on a machine where Java 1.7 was already installed on.

Note; It can also be that there are multiple java installations are set up on the server, with "java -version" on command shell you can investigate which javaversion is used by default.


Resolution

Java 1.7 is going to be supported in future, as a workaround until that time, start the Applications via batchmode with following command using a Java Version 1.6:

Studio:

java -cp "clearview_studio.jar;lib/*" com.automic.gwa.studio.Main

Admin:

java -cp "clearview_admin.jar;lib/*" com.automic.gwa.admin.Main -r -w

Attention; Java 1.7 also installs a java.exe under system32 folder in windows, please check beforehand with "java -version" on commandshell if the Java 1.6 is used by default, and if not, change the path of your default java installation.