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Jobs stop processing and get stuck in a QUEUED or a LAUNCH ERROR status.

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Article ID: 90118

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Jobs stop processing and get stuck in a QUEUED or a LAUNCH ERROR status.

Environment

Release: AAMOS499000-8.0-Automic Applications Manager-OS400 Agent
Component:

Resolution

Symptoms

Jobs stop processing and get stuck in a QUEUED or a LAUNCH ERROR status.


Cause

The table(s) displayed in the error message have been locked by another user other than the Applications Manager user.  In the example error message below the SYS user is locking the AW_JOB_QUEUE_ACTIVITY and the SO_JOB_QUEUE tables.

jdbc:oracle:thin:@MACHINE.COM:1527:user:APPWORX
java.sql.SQLException: ORA-20056: Could not lock jobid 12668026 in 30 secondsin 30 tries status=31-INITIATED AW_JOB_QUEUE_ACTIVITY is locked by OraUser=SYS,OSuser=spt, audsid=4294967295, ospid=34505, [email protected](TNS V1-V3). current audsid=89230129. SO_JOB_QUEUE is locked by OraUser=SYS,OSuser=APPWORX, audsid=89240113, ospid=, program=JDBC Thin Client. currentaudsid=89230129.
ORA-06512: at "APPWORX.AW5", line 509


Resolution

Please have your DBA unlock the tables mentioned in error message and restart Applications Manager.