CPs crash seeming randomly...
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CPs crash seeming randomly...

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Article ID: 90073

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

CPs crash seeming randomly...

Environment

Release: AOATAM99000-9.0-Automic-One Automation Tools-Application Manager
Component:

Resolution

Symptoms

Messages like the example below appear in the Windows Event logs:

(Sample from the application event log from a Windows 2008 server) 

Faulting application name: UCsrvcp.exe, version: 900.1.225.651, time stamp: 0x5050938e

Faulting module name: ntdll.dll, version: 6.1.7601.17725, time stamp: 0x4ec4aa8e

Exception code: 0xc0000374

Fault offset: 0x00000000000c40f2

Faulting process id: 0xd58

Faulting application start time: 0x01cdaa175724c964

Faulting application path: F:\UC4\AutomationEngine\bin\UCsrvcp.exe

Faulting module path: C:\Windows\SYSTEM32\ntdll.dll

Report Id: dd742e7c-17d2-11e2-9ce1-0050569d03e2

Fault bucket , type 0

Event Name: APPCRASH

Response: Not available

Cab Id: 0

Problem signature:

P1: UCsrvcp.exe

P2: 900.1.225.651

P3: 5050938e

P4: StackHash_f6a2

P5: 6.1.7601.17725

P6: 4ec4aa8e

P7: c0000374

P8: 00000000000c40f2

P9:

P10:

 


Cause

This problem with the CPs crashing can occur at the time of a dialog login because the user name contains a backslash character (\). The use of a backslash is not allowed in a user name.

 


Resolution

This issue can be avoided by not allowing backslashes as part of user names.  This will be resolved in the SP5 HF1 release for AE v9.