New Remote Agent not starting up with awcomm error
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New Remote Agent not starting up with awcomm error

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Article ID: 89833

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

New Remote Agent not starting up with awcomm error

Environment

CA Automic Applications Manager

 

Cause

During investigation, the AgentService##.log file showed the following error:

awcomm connection error : R:UC4_TEST 127.0.0.1:2136 <- 0.0.0.0/0.0.0.0:0

As per the above error message, the AgentService process on the Remote Agent is trying to connect to the awcomm process at the Master machine installed on the IP address of 127.0.0.1 and port 2136. This connection is failing.

When the awenv.ini files were looked at the Master and Remote Agent the following was observed. 

- Master's awenv.ini shows the awcomm was set to use port 2137.

AWCOMM_PORT=2137

- Agent's awenv.ini shows the awcomm port was set to use port 2136.

AWCOMM_PORT=2136

As the Remote Agents process(es) use the settings in awenv.ini to establish communication, it was trying to connect to the wrong port on the Master (where there was no awcomm process running) and failing.

Resolution

The solution to this was to set 'AWCOMM_PORT=2137' in the Remote Agent's awenv.ini file and stop/start the processes.