Issues starting PeopleSoft Agent
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Issues starting PeopleSoft Agent

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Article ID: 89803

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Issues starting PeopleSoft Agent

Environment

Release: AOATAM99000-9.0-Automic-One Automation Tools-Application Manager
Component:

Resolution

Symptoms

PeopleSoft Agent doesn't start.

The Agent log shows the message:

U2007021 Cannot find Java Class 'psft/pt8/joa/API'. Check CLASSPATH or generate it with the Application Designer.



Cause

Application can't find path to correct libraries.


Resolution

Verify they Java installed is a full version of Java and not part of another package, also verify the Java is 32 bit.  Then, do the following:


1) identify where the 32-bit java jre (please note java 1.7 is required for PT 8.53) is installed

2) Navigate to the 32-bit java jre's /bin/client folder (this is where jvm.dll should be located)

3) Copy the full path to that directory 

4) Edit your PATH environment variable so that the first entry is the full path from step 3 above

5) Confirm that this setting has been changed by opening a new windows command line session and typing in the following:

     echo %PATH%

The full path from step 3 above should be and be sure that that is the first entry in your PATH environment variable.  


For example:


C:\Program Files (x86)\Java\jre6\bin\client;C:\Program Files (x86)\Java\jre6\bin;(etc)


Next steps

If none of the above resolve the issue, please send Support the following:

*) The agent's ini file

*) The results of the following from command line for Windows:

     set

     java -version

*) OR the results of the following for UNIX/Linux:

    env

    java -version

    which java