ApplyPTF: Running the Applyptf tool on a Windows system with Norwegian localization fails with a message that it cannot connect to the registry.
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ApplyPTF: Running the Applyptf tool on a Windows system with Norwegian localization fails with a message that it cannot connect to the registry.

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Article ID: 8942

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When running the ApplyPTF tool from the CA Service Desk Manager primary server by double-clicking on the executable, even though the hostname of the local machine has been correctly entered in the "To Node" field, Applyptf fails and reports that the registry cannot be read.

For example, if the hostname is 'SDMW8B3', then the ApplyPTF message refers to 'SDMW8B3:', as shown in the following screenshot:

Environment

Clarity Service Management 17.2
Clarity Service Management 17.1

Cause

When the Windows locale is Norwegian, Applyptf adds a colon as a suffix to the hostname and then attempts to read the registry for a node with that name.  Because the node name no longer matches the hostname of the server, Applyptf attempts to locate the server with that name within the network and to read its registry.  Applyptf reports that the registry cannot be read.

Resolution

Run ApplyPTF in silent mode from the command line.

Additional Information

Additional information on using ApplyPTF in Silent mode, which also includes a script to simplify the task of installing a patch through ApplyPTF is available here:

https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=142076

To view the command line options of the ApplyPTF command, change the current directory to the directory that contains APPLYPTF.exe and then enter "Applyptf /?" on the command line. The results should be similar to the information in the following screenshot: