Autosys down after DB migration to another host: CAUAJM_E_18407 failed to connect to Oracle server ORA-12154: TNS: could not resolve the connect identifier specified
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Autosys down after DB migration to another host: CAUAJM_E_18407 failed to connect to Oracle server ORA-12154: TNS: could not resolve the connect identifier specified

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Article ID: 8918

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Updated On:

Products

CA Workload Automation AE - Scheduler (AutoSys) Autosys Workload Automation

Issue/Introduction

The DB team has migrated the Database to another host. 

The DB version is Oracle 11.2.0.3 and Autosys version is R11.3.

We have updated the tnsnames.ora file and the Autosys configuration file to point to the new Oracle SID.

Autosys still does not come up  with error:

CAUAJM_E_18407 failed to connect to Oracle server: mutilsys.world

CAUAJM_E_18400 An error has occurred while interfacing with ORACLE.

CAUAJM_E_18401 Function <Olog> invoked from <openProc> failed <233>

CAUAJM_E_18402 ORA-12154: TNS: could not resolve the connect identifier specified

Environment

CA-WAAE 11.3 with Oracle 11.2.0.3 on Linux.This problem might happen with another other Autosys release

Cause

In the customer environment, there were multiple TNS_NAMES variables pointing to different Oracle environments.

While logged on as "root" or "autosys", the execution of "echo $TNS_ADMIN" was showing another location which also contained a tnsnames.ora file.

But this location was not used by Autosys.

Resolution

The Autosys environment is set by the the different $AUTOUSER/autosys.*.<host_name> scripts.

In these scripts the TNS_NAMES variable is also set in the "# Set Oracle variables"  section and used by Autosys during its startup.

By updating the tnsnames.ora file pointed to by variable $TNS_ADMIN, which is  set in the $AUTOUSER/autosys.*.<host_name> script, fixed the problem.

Additional Information

When executing, unisrvcntr start xxxxx  , to start Autosys, environment profile $AUTOUSER/autosys.sh.<host_name> is always executed.